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Preface 

Security information 
IDEC SmartRelay provides products and solutions with industrial security functions that 
support the secure operation of plants, systems, machines and networks. 

In order to protect plants, systems, machines and networks against cyber threats, it is 
necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial 
security concept.  

Customers are responsible for preventing unauthorized access to their plants, systems, 
machines and networks. Such systems, machines and components should only be 
connected to an enterprise network or the internet if and to the extent such a connection is 
necessary and only when appropriate security measures (e.g. firewalls and/or network 
segmentation) are in place.  

IDEC SmartRelay products and solutions undergo continuous development to make them 
more secure. IDEC strongly recommends that product updates are applied as soon as they 
are available and that the latest product versions are used. Use of product versions that are 
no longer supported, and failure to apply the latest updates may increase customers' 
exposure to cyber threats.  

General introduction 
FL1F Web Editor is used together with IDEC SmartRelay Base Module (BM) and WindLGC. 
This tool helps you create user-defined web pages in the Editor pane, and visually view the 
whole project through Web Server of IDEC SmartRelay Base Module. 

With FL1F Web Editor, you can: 
● integrate different components including some variables conveniently;

● customize individual web pages.

Comparison between BM version number and hardware type in WindLGC 

BM version number Hardware type in WindLGC 
FL1F FS4 or previous version FL1F 
FL1F FS5 or later version FL1F FS5 

Note 

You can find the BM version number on the base module. For more detailed information, 
refer to the user’s manual. 
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Document History 
The following edition of FL1F Web Editor has been published: 

Edition Version Comment 
02/2019 V1.0 First edition 

Basic concept 
Having a general idea of FL1F Web Editor is the prerequisite for using it. The basic concept 
about the whole project is as follows: 

Project 

In FL1F Web Editor, project contains Pages and a Navigator. Each page contains pre-
defined components, such as Text, Image, Digital Value and etc. Global Tag is defined for 
facilitating end user to bind components and variables. 

Pages 

Pages contains a Home page and some user-defined pages. Home page is a default page, 
while you can determine whether to create user-defined pages according to your 
requirements. Either page or Home Page is a web page, and you can visit it in web browser 
after deploying a project to IDEC SmartRelay BM. 

Navigator 

Navigator is a floating page of the web site and it intended to aid users to switch between 
different web pages or log off during the runtime operation.  

Component 

FL1F Web Editor contains a couple of pre-defined components for web page. Each 
component has different render effect in web page. Each component contains some 
properties. 

Variable 

Variable is read/write data element of IDEC SmartRelay BM, such as I, Q, AI, AQ and etc. 
Variable can be bound with component. You can read/write variable via components. 

Global Tag 

Global Tag is the alias of variable and it can be bound with some components. 

Tag Table 

Tag Table is a place to define Global Tags, and you can add, modify, and delete Global 
Tags here. 

Private Tag 

Private Tag is used for binding variable to component directly and you do not need to define 
Global Tags. 
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Compatibility 
FL1F Web Editor is available for: 
● IDEC SmartRelay Base Module: FL1F FS5

● Java Runtime Environment 1.8.0_121, which is recommended 
version.

● the following types of web browsers which support HTML5:

– Microsoft Internet Explorer with minimum version 10.0

– Mozilla Firefox with minimum version 11.0

– Google Chrome with minimum version 16.0

– Apple Safari with minimum version 5.0

● the following versions of operating system:

– Windows 32 & 64 bit, including Windows 7 and Window 10. 
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User interface 1
1.1 User interface - Overview 

User interface 
FL1F Web Editor starts with an empty pane for the project.  

When you create a new project, the user interface appears as follow: 
● A new project appears in Project tree.

● Component pane contains all the component information.

● An empty window for Home Page in the Editor pane.

● Property pane contains the properties information for the Home Page.

To help you maintain an overview of a complete project, the right side and the bottom of the 
Editor pane contain scroll bars, which you can use for vertical and horizontal scrolling of the 
project editing. 

① Menu bar ④ Component pane

② Standard toolbar ⑤ Editor pane

③ Project tree pane ⑥ Property pane
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Menu bar 
The top of the FL1F Web Editor window contains the menu bar (Page 13). Here, you can 
find various commands for editing and managing your projects, as well as functions for 
defining your default settings and for transferring of the project to and from IDEC 
SmartRelay. 

Standard toolbar 
The standard toolbar (Page 13) appears above the Project tree and Editor pane's interface. 
Initially, FL1F Web Editor shows you a reduced standard toolbar that provides only the 
essential functions.  

The standard toolbar provides direct access to the essential functions of FL1F Web Editor. 

After you open a project for editing, you can see the complete standard toolbar. 

You can use these icons to create a new project or download, save an existing project, 
undo/redo the last action, or initiate data transferred to and from IDEC SmartRelay devices. 

1.2 Function keys and shortcuts 
FL1F Web Editor provides the following function key and shortcuts for frequently called 
functions:  

Function key in FL1F Web Editor: 

[F1] Help -> Help Contents (Page 25) 

Shortcuts in FL1F Web Editor: 

In the File menu (Page 14): 
[Ctrl+Shift+N] File -> Open Project (Page 15)  
[Ctrl+F4] File -> Close Project (Page 16) 
[Ctrl+S] File -> Save (Page 16)  
[Ctrl+Shift+S] File -> Save All (Page 16) 
[Alt+F4] File -> Exit (Page 16)  

In the Edit menu (Page 17): 
[Ctrl+Y] Edit -> Redo (Page 18)  
[Ctrl+Z] Edit -> Undo (Page 18) 
[Ctrl+A] Edit -> Select All (Page 18)  
[Ctrl+C] Edit -> Copy (Page 18)  
[Ctrl+V] Edit -> Paste (Page 19)  
[Delete] Edit -> Delete (Page 19) 
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In the Tools menu (Page 19): 
[Ctrl+D] Tools -> Download (Page 19)  
[Ctrl+U] Tools -> Upload (Page 21)  

In the Window menu (Page 23): 
[Ctrl+1] Window -> Project (Page 23) 
[Ctrl+2] Window -> Properties (Page 24) 
[Ctrl+3] Window -> Component (Page 24) 

1.3 Standard toolbar overview 
The icons of the standard toolbar provide quick access to commands that are also available 
on the menu.  

In FL1F Web Editor, you can use the mouse-over-button function to display the icon name, 
which represents the tooltip. This helps you quickly recall the function of the icon, without 
calling the menu or the help. 

The following commands are found in the standard toolbar: 

File: New Project (Page 14)  
Open Project (Page 15)  
Close Project (Page 16) 
Save (Page 16)  
Save all (Page 16)  

Edit: Left Rotate (Page 18)  
Right Rotate (Page 17)  
Redo (Page 18) 
Undo (Page 18) 

Tools: Download (Page 19) 
Upload (Page 21) 
Deploy To SD Card (Page 22) 

1.4 Menu bar 
The menu bar contains some editing functions for the project and provides access to the 
context-sensitive help. 
● File menu (Page 14)

● Edit menu (Page 17)

● Tools menu (Page 19)

● Window menu (Page 23)

● Help menu (Page 24)
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1.4.1 File menu 
The File menu command contains commands for file management. Included are also 
commands for creating, saving or exit:  

● New Project (Page 14)

● Open Project (Page 15)

● Close Project (Page 16)

● Save (Page 16)

● Save All (Page 16)

● Save As... (Page 16)

● Exit (Page 16)

1.4.1.1 File -> New Project 

Click this command to open a New Project dialog box which contains name, location and 
resolution information. 
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Name and Location dialog box 
● Project Name: give a valid name to the project.

Note 
Naming Conventions for the Project Name 
• The maximum length of a name is 8.
• The maximum length of filename extension is 3.
• Do not use space in the file name.
• Do not assume case sensitivity.
• Do not use the following characters:

– < (less than)
– > (greater than)
– : (colon)
– " (double quote)
– / (forward slash)
– \ (backslash)
– | (vertical bar or pipe)
– ? (question mark)
– * (asterisk)

● Project Location: click Browse button and select a proper location in your computer to
save the project.

● Default Resolution: click the drop-down menu and select a resolution for the project.

After modifying this dialog box, click Finish button to accomplish the new project creation. 
Then a new project appears in Project tree. 

You can also click Cancel button to cancel the creation or click Help button to get more 
information from online help.  

The standard toolbar (Page 13) also contains an icon for this menu command. 

1.4.1.2 File -> Open Project 

Click this command to open a dialog box from which you can select and open a previously 
created project for further editing.  

The type of file that you can open is only for Project Folder. 

The icon for the Project Folder is   . 

The standard toolbar (Page 13) also contains an icon for this menu command. 
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1.4.1.3 File -> Close Project 

Click this command to close the active project window. If you have not yet saved the current 
project, FL1F Web Editor prompts you to save it.  

The standard toolbar (Page 13) also contains an icon for this menu command. 

1.4.1.4 File -> Save 

Click this command to save the current editor pane. 

For other opened windows, you can save them with Save all. You can find additional 
information under File -> Save All (Page 16).  

If you are saving a modified version of an existing project, FL1F Web Editor performs a quick 
save. The revised version overwrites the old version at the same path and name as the 
source file. 

The standard toolbar (Page 13) also contains an icon for this menu command. 

1.4.1.5 File -> Save All 

Click this command to save all the corrections for project in editor pane. 

The revised version overwrites the old version at the same path and name as the source file. 

The standard toolbar (Page 13) also contains an icon for this menu command. A click on this 
menu command closes all open windows.  

1.4.1.6 File -> Save As... 

After clicking this command, a dialog box opens for you to specify the path and project name 
under which the current project is to be saved. This allows you to save modified projects 
under a different name or folder, and thus keep previous versions for retrieval.  

The only type of files that you can save is project folder. Each project is saved in its own 
project folder. 

1.4.1.7 File -> Exit 
Click this command to close FL1F Web Editor tool. 

If you are editing a project and have not yet saved it, FL1F Web Editor prompts you about 
your project. 

Below is an example for the pop-up window: 
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In this pop-up window, you can decide which windows are need to be saved. You can click 
Save to save the current window or click Save All to save project. 

Alternatively, you can exit FL1F Web Editor without saving windows by clicking Discard All. 

You can also click Cancel button to cancel the creation or click Help button to get more 
information from online help. 

1.4.2 Edit menu 
The Edit menu provides commands for editing your project. The toolbar contains some of the 
basic commands for creating and editing projects.  
● Right Rotate (Page 17)

● Left Rotate (Page 18)

● Redo (Page 18)

● Undo (Page 18)

● Select All (Page 18)

● Bring to front (Page 18)

● Send to back (Page 18)

● Copy (Page 18)

● Paste (Page 19)

● Delete (Page 19)

1.4.2.1 Edit -> Right Rotate 

Click this command to rotate the component clockwise. Once you select the component, and 
then click the Right Rotate button, you can rotate the component 90 degrees clockwise.  

The standard toolbar (Page 13) also contains an icon for this menu command. 
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1.4.2.2 Edit -> Left Rotate 

Click this command to rotate the component anticlockwise. Once you select the component, 
and then click the Left Rotate button, you can rotate the component 90 degrees 
anticlockwise.  

The standard toolbar (Page 13) also contains an icon for this menu command. 

1.4.2.3 Edit -> Redo 

Click this command to revert the last undo action.  

The standard toolbar (Page 13) also contains an icon for this menu command. 

1.4.2.4 Edit -> Undo 

Click this command to undo the previous actions.  

The standard toolbar (Page 13) also contain an icon for this menu command. 

1.4.2.5 Edit -> Select All 
Click this command to select all components in current Pages or Navigator under the project, 
for example, Polyline, Rectangle, Image or Navigator Item can be selected on the Editor 
pane. You cannot use this command to select the component in Global Tags. 

1.4.2.6 Edit -> Bring to front 
Click this command to move a component to the top position in its group or layer. 

1.4.2.7 Edit -> Send to back 
Click this command to move a component to the bottom position in its group or layer. 

1.4.2.8 Edit -> Copy 

Click this command to copy one or more selected components to the clipboard, for example, 
you can copy the selected Polyline, Rectangle, Image and Navigator Item from the Editor 
pane to the clipboard. 
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1.4.2.9 Edit -> Paste 

Click this command to copy the clipboard content to the Editor pane. 

1.4.2.10 Edit -> Delete 

Click this command to delete the selected components, without copying them to the 
clipboard. You can retrieve deleted components with the Undo function.  

When you delete the selected components, a pop-up window of Confirm Object Deletion 
appears. You can confirm the deletion with Yes button or cancel the deletion with No button 
in the pop-up window. 

1.4.3 Tools menu 
The tools menu provides the following menu commands: 
● Download (Page 19)

● Upload (Page 21)

● Deploy To SD Card (Page 22)

● Options (Page 22)

1.4.3.1 Tools -> Download 

Click this command to download a FL1F Web Editor project from PC to the Micro SD card of 
IDEC SmartRelay Base Module. You can also use this button in the standard toolbar 
(Page 13) for such purpose. 
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Example for Download 
To download a new project to IDEC SmartRelay Base Module, do the following steps: 
1. Click the icon  in the standard toolbar or select Download from Tools bar.

2. In the pop-up Download window,

– select correct Interface from the drop-down menu;

– enter the valid Target IP Address or click scan icon  to find the accessible device to 
connect the BM. 

– click Test button, and then a Connecting pane pops up.

– after the connection line turns green, click OK button. You can also click Cancel button
to cancel the configuration or click Help button to get more information from online
help.
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3. In the Confirm Download pane, click OK button to confirm to download the project.

Then the project is downloaded to IDEC SmartRelay BM. 

4. In the Confirm pane, click OK button to start the BM.

1.4.3.2 Tools -> Upload 

Click this command to upload a FL1F Web Editor project from the Micro SD card of IDEC 
SmartRelay Base Module to PC. You can also use this button in the standard toolbar 
(Page 13) for such purpose. 
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1.4.3.3 Tools -> Deploy To SD Card 

Click this command to deploy the project to Micro SD card, the following dialog box opens 
and you can specify the driver under which you want to save your project.  

The standard toolbar (Page 13) also contains an icon for this menu command. 

1.4.3.4 Tools -> Options 
Here you can select Language and Size of the text & icons options for FL1F Web Editor, 
click the radio button before each options and press OK button to save the selection. 

You can also click Cancel button to cancel the selection or click Help button to get more 
information from online help. 

Language 

Here you can define the user interface language. 
● Deutsch

● English

● Japanese

Size of the text & icons 

Here you can select the size of the text and icons in the user interface. 
● 100%

● 120%

● 150%
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Note 

The changes for options will not take effect until you restart FL1F Web Editor. 

1.4.4 Window menu 
From the Window menu, you can arrange your project windows on the desktop. You can 
show the Project tree pane, Component pane, Editor pane and Property pane on the 
desktop. 

The following window options are available: 
● Project (Page 23)

● Properties (Page 24)

● Component (Page 24)

1.4.4.1 Window -> Project 
You can use this menu command to show the Project tree pane on the desktop. If you want 
to close the Project tree pane, click the  cross button. 
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1.4.4.2 Window -> Properties 
You can use this menu command to show the Property pane on the desktop. If you want to 
close the Property pane, click the  cross button. 

1.4.4.3 Window -> Component 
You can use this menu command to show the Component pane on the desktop. If you want 
to close the Component pane, click the  cross button.  

1.4.5 Help menu 
This menu provides you with help and information on FL1F Web Editor. 

● Start Page (Page 24)

● Help Contents (Page 25)

● About (Page 25)

1.4.5.1 Help -> Start Page 
Close the whole project or close all the windows in Editor pane, and then exit the FL1F Web 
Editor, when you restart the FWE again, you can see the Start Page shows in the Editor 
pane.  
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If you exit the FL1F Web Editor without closing the edited project, when you restart the FWE 
again, the last edited pages show in the Editor pane. 

1.4.5.2 Help -> Help Contents 

The Online Help 
The online help quickly and reliably provides you with information about projects, tools and 
the creation of projects with FL1F Web Editor.  

Topics of the Online Help 
The User interface (Page 11) section describes the user interface with its toolbars and the 
FL1F Web Editor menus in detail. 

Refer to the Tutorial (Page 49) for a quick and easy introduction to the basics of operating 
FL1F Web Editor.  

The section of Getting started with project creation (Page 49) that takes you a general 
description for creating a new project, and towards the end of this section you will find an 
extensive Practical example (Page 50) that takes you through all the steps of project 
creation. 

The Tips and Tricks (Page 67) section includes information about operating tips with FL1F 
Web Editor. 

The online help includes an index as well as a full text search feature for keyword and 
terminology based searches. 

1.4.5.3 Help -> About 
The General tab displays the version number and the release version of your FL1F Web 
Editor tool.  

The System tab provides you with information on the version of the Java Runtime 
environment used, the program paths, the installed operating system and on the memory 
used. 

The Notice tab provides you with information on the Commercial Features in Java SE 
Product Editions. 

1.5 Projects Tree 
In the Project tree pane, you can configure and manage your projects. When you create a 
new project from the menu bar of File -> New Project (Page 14), FL1F Web Editor creates a 
new project with a Pages, a Global Tags and a Navigator automatically.  
● Pages (Page 26)

● Global Tags (Page 27)

● Navigator (Page 28)
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1.5.1 Pages 

Pages is a container of your pages. You can define the web pages here. After finish editing 
the pages, you can save them as HTML files and view them in web browser. 

The Pages contains one default Home Page and other pages. 
● Home Page

This is the home page for your project, and the Home page cannot be deleted. You can 
open it by double-clicking the Home page icon, or right-clicking the Home page icon and 
select Open button. 

● Other pages

These are the other user-defined pages for your project. You can open it by double-
clicking the page icon, or right-clicking the page icon and select Open button. 

Edit the user-defined page 

When you create a new project (Page 49), the new project contains three parts: Pages, 
Global Tags and Navigator. The Home Page appears under the Pages in the Project tree 
automatically.  

1. To create a new page, right-click the Pages icon  and select New Page button, a new
page_1 appears under the Home Page and the new page is opened in Editor pane
automatically.

2. To open, delete or rename the new page, right-click the page_1 icon and select the
corresponding options depending on your need, for example, select Open, Delete or
Rename option from the shortcut menu.

3. After editing the page, click the  icon in standard toolbar  (Page 13) or select File ->
Save (Page 16) from the File menu to save the change.

The Properties for Pages: 
● Basic

– Name: Page

– Resolution: you can modify the width and height information from the Size pane.

● Styles

– Background Image: select the appropriate pictures for current page from Graph
Library when you need or leave it empty for none.

Note 

Graph Library is the FL1F Web Editor build-in graphics library. It contains three parts: 
Build-In Graph, Color and My Graph. You can choose any of the graphic for the image by 
selecting the picture, and confirm the selection by clicking OK button. For detailed 
information, refer to the chapter Graph Library (Page 45). 
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1.5.2 Global Tags 

Global Tag is the alias of IDEC SmartRelay BM variable and it can be bound with some 
components, and Tag Table is a place to define Global Tags. 

The Global Tags only contains one Tag Table, and the Tag Table cannot be deleted. 
● Tag Table

Tag Table is a table with ID, Name, Block Type, Block Number and Access Mode 
information, and it is the place for storing the variable data information for your project. 

Block number varies according to the corresponding block type, for the detailed 
information, refer to the following table. 

Block Type Block Number 
I I1-I24 
Q Q1-Q20 
M M1-M64 
AI AI1-AI8 
AQ AQ1-AQ8 
AM AM1-AM64 
V V: 0-850 

Bits: 0-7 
VD VD: 0-847 
VW VW: 0-849 
Cursor Key C1-C4 
Function Key F1-F4 
Shift Register S1.1-S1.8,S2.1-S2.8, S3.1-S3.8,S4.1-

S4.8 

Edit the Tag Table 

When you create a new project (Page 49), the new project contains three parts: Pages, 
Global Tags and Navigator. The Tag Table appears under the Global Tags as a subpage in 
the Project tree automatically. 
1. To open the Tag Table in the Editor pane:

– Right-click the Tag Table icon  and select Open button;

– Or double-click the Tag Table icon  .

2. To edit the Tag Table by clicking Add or Delete button to add or remove the variable, and
do the following for each variable.

– Define the alias name for the variable by double-clicking the Name column;

– Select Block type from the drop-down menu, and select corresponding value for each
Block type in Block Number.

3. After editing the Tag Table, click the Apply button or icon  in standard toolbar
(Page 13)or select File -> Save (Page 16) from the File menu to save the change.
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1.5.3 Navigator 

Navigator is a floating page of the web site and it is intended to aid users to switch among 
different web pages or log off during the runtime operation.  

Edit the Navigator 

When you create a new project (Page 49), a Navigator appears in the Project tree. 
1. To open the Navigator in the Editor pane:

– Right-click the Navigator icon  and select Open button;

– Or double-click the Navigator icon  .

2. To edit the Navigator by dragging the Navigator Item component under the Navigation bar
directly, and do the following in the Property pane:

– Modify the font for the text in the navigator by selecting the value and clicking the OK
button in Font;

– Define the Navigator Item name by modifying the content in Text;

– Link to each pages by selecting the pages which you have created from the drop-
down menu.

3. After editing the Navigator, click the icon  in standard toolbar  (Page 13) or select File ->
Save (Page 16) from the File menu to save the change.

The Properties for Navigator Item: 
● Basic

– Name: Navigator Item

– Location: you can only check the location coordinate from the Location pane.

– Size: you can only check the width and height information from the Size pane.

● Styles

– Font: select Font, Font Style and Size depending on your need. Click the OK button
for save the correction or click the Reset to Default button to reset to the default
setting.

● Values

– Text: Type the Navigator Item name for each page.

– Link: select Home Page or other page name that you have created in the drop-down
menu.
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1.6 Components pane 
In the Component pane, according to different functions, all the components can be 
classified to five segments: Tool, Basic, Digital, Analog and Miscellaneous.  

You can configure the component based on your requirements. 

Tool 
Polyline (Page 29) Rectangle (Page 30) Circle (Page 31) 

Basic 
Text (Page 32) Image (Page 34) Link (Page 34) 

Digital 
Digital Value (Page 36) 

Analog 
Analog Value (Page 38) Analog Bar (Page 39) Analog Slider (Page 40) 

Miscellaneous 
Scale Time (Page 41) BM Clock (Page 43) 

1.6.1 Tool 
Tool is generally used for editing basic graphics. 

Tool contains the following selections:  
● Polyline (Page 29)

● Rectangle (Page 30)

● Circle (Page 31)

1.6.1.1 Polyline 

 Use the Polyline component when you want to draw one polyline. 

Draw the polylines 
1. Select the Polyline component   .

2. Position the pointer where you want the line to begin in the Editor pane, drag to where
you want the line to end by right-clicking the mouse or pressing Esc button. Each point
you click appears a blue square.

3. Do one of the following:

– To modify the track of the polyline, drag the blue square for the point.

– To move the component, drag it without clicking the blue squares on the line.

– To click the polyline, specify the weight and line style of the polyline in the Property
pane. If you want to fill the polyline with the color, select Color swatches.
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The Properties for Polyline: 
● Basic

– Name: Polyline

● Styles

– Weight: enter the width of the polyline.

– Color: click color swatches, select a color swatch, and click OK button.

– Dashed: select different polyline types  Solid, Round Dot, Square Dot, Dash, Dash
Dot, Long Dash, Long Dash Dot or Long Dash Dot Dot depending on your need.

– Transparency: value ranges from 1 to 100, adjust the value depending on your need.

1.6.1.2 Rectangle 

Use the Rectangle component when you want to draw a rectangle or a square. 

Draw rectangles and squares 
1. Select the Rectangle component   .

2. Draw a rectangle or a square by dragging the Rectangle component directly where you
want it to be in the Editor pane.

3. Do one of the following:

– To adjust the rectangle or square's dimension, drag the blue square on the borderline
until the rectangle or square is the desired size, or specify the value for Location and
Size in the Property pane.

– To move the component, drag it without clicking the blue squares on the borderline.

– To select the rectangle or square, specify the Border Width and Border Style in the
Property pane. If you want to fill border and background with the color, select color
swatches separately.
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The Properties for Rectangle: 
● Basic

– Name: Rectangle

– Location: you can modify the location coordinate for the rectangle.

– Size: you can modify the width and height information for the rectangle.

● Styles

– Border Width: adjust the value depending on your need.

– Border Style: select dotted, dashed,solid or double depending on your need.

– Border Color: click Border Color swatches, select a swatch, and click OK button.

– Background Color: click Background Color swatches, select a swatch, and click OK
button.

– Transparency: value ranges from 1 to 100, adjust the value depending on your need.

– Fill: click the check box depending on whether to fill the rectangle with background
color.

1.6.1.3 Circle 

Use the Circle component when you want to draw a circle or an ellipse. 

Draw circles and ellipses 

1. Select the Circle component  . 

2. Draw a circle by dragging the Circle component directly where you want it to be in the
Editor pane.

3. Do one of the following:

– To adjust the circle dimension, drag the blue square on the borderline until the circle is
the desired size, or specify the value for Location and Size in the Property pane.

– To draw an ellipse, drag the circle component into the editor pane, and then drag the
blue square on the borderline until the ellipse is the desired size, or specify the value
for Location and Size in the Property pane.

– To move the component, drag it without clicking the blue squares on the borderline.

– To select the circle or ellipse, specify the Border Width and Border Style in the
Property pane. If you want to fill border and background with the color, select color
swatches separately.



User interface 
1.6 Components pane 

32 FL1F Web Editor Online Help  

The Properties for Circle: 
● Basic

– Name: Circle

– Location: you can modify the location coordinate for the circle.

– Size: you can modify the width and height information for the circle.

● Styles

– Border Width: adjust the value depending on your need.

– Border Style: select dotted, dashed, solid or double depending on your need.

– Border Color: click Border Color swatches, select a swatch, and click OK button.

– Background Color: click Background Color swatches, select a swatch, and click OK
button.

– Transparency: value ranges from 1 to 100, adjust the value depending on your need.

– Fill: click the check box depending on whether to fill the circle with background color.

1.6.2 Basic 
Basic is generally used for adding texts, images and links in your project. 

Basic contains the following selections:  
● Text (Page 32)

● Image (Page 34)

● Link (Page 34)

1.6.2.1 Text 

Use the Text component when you want to add word description. 

Enter the text 

The text begins where you drag the Text component. When the text reaches a boundary, it 
automatically wraps to fit inside the defined area.  
1. Select the Text component  . 

2. Drag the Text component directly where you want the line of text to be in the Editor pane.

3. Enter the text by double-clicking the text component to edit inline or changing the Text
Value in the Property pane.
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4. Press esc key or click other area to exit edit mode.

5. When you finish editing text,

– modify the content by double-clicking the text component to edit inline or changing the
Text Value in the Property pane;

– adjust the text area by dragging the blue square on the border or modifying the value
for Size in the Property pane;

– move the text by dragging the component without clicking the blue squares on the
borderline.

The Properties for Text: 
● Basic

– Name: Text

– Location: you can modify the location coordinate for the text.

– Size: you can modify the width and height information for the text.

● Styles

– Font: select Font, Font Style and Size information separately in the Font pane. Click
the OK button for save the correction or click the Reset to Default button to reset to
the default setting.

– Text Color: click Text Color Swatches, select a swatch, and click OK button.

– Background Color: click Background Color swatches, select a swatch, and click OK
button.

– Fill: click the check box depending on whether to fill the text area with background
color.

● Values

– Text Value: type the content.
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1.6.2.2 Image 

Use the Image component when you want to add an image. 

Create an Image 

The image begins where you drag the Image component. Each image is independent. 
1. Select the Image component  .

2. Drag the Image component directly where you want the image to be in the Editor pane.

3. When you create an image,

– adjust the image dimension by dragging the blue square on the border or modifying
the value for Size in the Property pane;

– edit the image in the Property pane by selecting the appropriate pictures for image in
Graph Library;

– move the component by dragging it without clicking the blue squares on the
borderline.

The Properties for Image: 
● Basic

– Name: Image

– Location: you can modify the location coordinate for the image.

– Size: you can modify the width and height information for the image.

● Values

– Image: select the appropriate pictures from Graph Library.

1.6.2.3 Link 

Use the Link component when you want to add a Uniform Resource Locator (URL) link. 

Create a link 

The link begins where you drag the Link component. Each link is independent. 
1. Select the Link component  .

2. Drag the Link component directly where you want the line of link to be in the Editor pane.
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3. When you edit the link,

– double-click the link component to edit inline or change the Text Value in the Property
pane;

– enter the Url value in the Property pane.

4. After you create the link,

– adjust the link dimension by dragging the blue square on the border or modifying the
value for Size in the Property pane;

– move the component by dragging it without clicking the blue squares on the
borderline.

Note 

If you enter more text than can fit within link area, the apostrophe (...) appears in the end 
of the link area. You should adjust the link area by dragging the blue square on the 
border or modifying the value for Size in the Property pane. 

The Properties for Link: 
● Basic

– Name: Link

– Location: you can modify the location coordinate for the link.

– Size: you can modify the width and height information for the link.

● Styles

– Font: select Font, Font Style and Size information separately in the Font pane. Click
the OK button for save the correction or click the Reset to Default button to reset to
the default setting.

– Text Color: click Text Color Swatches, select a swatch, and click OK button.

– Background Color: click Background Color swatches, select a swatch, and click OK
button.

– Fill: click the check box depending on whether to fill the link area with background
color.

● Values

– Text Value: Type the content for the link.

– Url: Type the URL link.
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1.6.3 Digital 
Digital Value is used for presenting the digital value "0" and "1" visually. 

Digital Value only contains one selection:  
● Digital Value (Page 36)

1.6.3.1 Digital Value 

Use the Digital Value component when you want to present the digital value "0" and "1" 
visually. "0" is for "off-state", and "1" is for "on-state". 

Create the digital value 

1. Select the Digital Value component  .

2. Drag the Digital Value component directly where you want it to be in the Editor pane.

3. When you create a digital value,

– adjust the dimension by dragging the blue square on the border or modifying the value
for Size in the Property pane;

– edit the digital value by selecting corresponding value for Variable and Animation in
the Property pane;

– move the component by dragging it without clicking the blue squares on the
borderline.
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The Properties for Digital Value: 
● Basic

– Name: Digital Value

– Location: you can modify the location coordinate for the digital value.

– Size: you can modify the width and height information for the digital value.

● Variable

– Variable Name: select the Private Tag or Global Tag depending on your need.

– Variable Type: select I, Q, M , V , Cursor Key, Function Key or Shift Register for the
type of variable.

– Block Number: follow the below table to select each value.

– Writable: click the check box depending on whether you have the write function. For
detailed information, refer to the following table.

Block Type Block Number Writable 
I I1-I24 Read Only 
Q Q1-Q20 Read and Write 
M M1-M64 Read and Write 
V VB: 0-850 Read and Write 

Bits: 0-7 Read and Write 
Cursor Key C1-C4 Read Only 
Function Key F1-F4 Read Only 
Shift Register S1.1-S1.8,S2.1-S2.8, 

S3.1-S3.8,S4.1-S4.8, Read Only 

● Animation

– On Image: select the appropriate pictures for on-state in Graph Library.

– Off Image: select the appropriate pictures for off-state in Graph Library.

– On Text: enter the display content for on-state.

– Off Text: enter the display content for off-state.

1.6.4 Analog 
Analog Value  is used for editing analog variable visually. 

Analog Value contains the following selections: 
● Analog Value (Page 38)

● Analog Bar (Page 39)

● Analog Slider (Page 40)
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1.6.4.1 Analog Value 

Use the Analog Value component when you want to show the analog value. 

Create an analog value 

1. Select the Analog Value component  .

2. Drag the Analog Value component directly where you want it to be in the Editor pane.

3. When you create the analog value,

– adjust the dimension by dragging the blue square on the border or modifying the value
for Size in the Property pane;

– edit the analog value by selecting corresponding value for Variable in the Property
pane.

– move the component by dragging it without clicking the blue squares on the
borderline.

The Properties for Analog Value: 
● Basic

– Name: Analog Value

– Location: you can modify the location coordinate for the analog value.

– Size: you can modify the width and height information for the analog value.

● Variable

– Variable Name: select the Private Tag or Global Tag depending on your need.

– Block Type: select AI, AQ, AM, VB, VD or VW for the type of variable.

– Block Number: follow the below table to select each value.

– Block Format: select Hex, Binary, Signed or Unsigned for display format.

– Unit: select appropriate units.

– Writable: click the check box depending on whether you have the write function. For
detailed information, refer to the following table.

Block Type Block Number Writable 
AI AI1-AI16 Read Only 
AQ AQ1-AQ16 Read and Write 
AM AM1-AM64 Read and Write 
VB 0-850 Read and Write 
VD 0-847 Read and Write 
VW 0-849 Read and Write 
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1.6.4.2 Analog Bar 

Use the Analog Bar component when you want to create an analog bar to show the dynamic 
variable. 

Create an analog bar 
1. Select the Analog Bar component  .

2. Drag the Analog Bar component directly where you want it to be in the Editor pane.

3. When you create an analog bar,

– adjust the dimension by dragging the blue square on the border or modifying the value
for Size in the Property pane;

– edit the analog bar value by selecting corresponding value for Variable and Animation
in the Property pane;

– move the component by dragging it without clicking the blue squares on the
borderline.

The Properties for Analog Bar: 
● Basic

– Name: Analog Bar

– Location: you can modify the location coordinate for the analog bar.

– Size: you can modify the width and height information for the analog bar.

● Variable

– Variable Name: select the Private Tag or Global Tag depending on your need.

– Block Type: select AI, AQ, AM, VB, VD or VW for the type of variable.

– Block Number: select each value according to the below table.

Block Type Block Number 
AI AI1-AI16 
AQ AQ1-AQ16 
AM AM1-AM64 
VB 0-850

VD 0-847

VW 0-849

● Animation

– Max. Value: set the maximum value for the analog bar depending on your need.

– Min. Value: set the minimum value for the analog bar depending on your need.

– Scale: set the scale for the analog bar depending on your need.

– Color: click Color Setting swatches, according to different ranges, select a
corresponding color swatch, and click OK button.
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1.6.4.3 Analog Slider 

Use the Analog Slider component when you want to create an analog slider to show the 
slider variable. 

Create an analog slider 
1. Select the Analog Slider component  .

2. Drag the Analog Slider component directly where you want it to be in the Editor pane.

3. When you create an analog slider,

– adjust the dimension by dragging the blue square on the border or modifying the value
for Size in the Property pane;

– edit the analog slider value by selecting corresponding value for Variable and
Animation in the Property pane;

– move the component by dragging it without clicking the blue squares on the
borderline.
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The Properties for Analog Slider: 
● Basic

– Name: Analog Slider

– Location: you can modify the location coordinate for the analog slider.

– Size: you can modify the width and height information for the analog slider.

● Variable

– Variable Name: select the Private Tag or Global Tag depending on your need.

– Block Type: select AI, AQ, AM, VB, VD or VW for the type of variable.

– Block Number: follow the below table to select each value.

– Writable: click the check box depending on whether you have the write function. For
detailed information, refer to the following table.

Block Type Block Number Writable 
AI AI1-AI16 Read Only 
AQ AQ1-AQ16 Read and Write 
AM AM1-AM64 Read and Write 
VB 0-850 Read and Write 
VD 0-847 Read and Write 
VW 0-849 Read and Write 

● Animation

– Max. Value: set the maximum value for the Analog Slider depending on your need.

– Min. Value: set the minimum value for the Analog Slider depending on your need.

– Background Image: select the appropriate picture from Graph Library.

– Thumb Image: select the appropriate picture from Graph Library.

1.6.5 Miscellaneous 
Miscellaneous  is used for other functions. 

Miscellaneous contains two selections: 
● Scale Time (Page 41)

● BM Clock (Page 43)

1.6.5.1 Scale Time 

Use the Scale Time component when you want to display a time value. 
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Scale time is the actual value of a referenced function block which displayed as a time value. 
Possible time display formats are shown as below: 
● hours : minutes : seconds . milliseconds

● hours : minutes : seconds

● hours : minutes

● hours

Create a scale time 
1. Select the Scale Time component   .

2. Drag the Scale Time component directly where you want it to be in the Editor pane.

3. When you create a scale time,

– adjust the dimension by dragging the blue square on the border or modifying the value
for Size in the Property pane;

– edit the scale time value by selecting corresponding value for Variable in the Property
pane;

– move the component by dragging it without clicking the blue squares on the
borderline.

The Properties for Scale Time: 
● Basic

– Name: Scale Time

– Location: you can modify the location coordinate for the scale time.

– Size: you can modify the width and height information for the scale time.

● Variable

– Variable Name: select the Private Tag or Global Tag depending on your need.

– Block Type: select AI, AQ, AM, VB, VD or VW for the type of variable.

– Block Number: following the below table to select each value.

– Time Unit: select Hours(h), Minutes(m), Seconds(s) or 10Milliseconds(ms) unit
depending on your need.

– Writable: click the checkbox depending on whether you have the write function. For
detailed information, refer to the following table.

Block Type Block Number Writable 
AI AI1-AI16 Read Only 
AQ AQ1-AQ16 Read and Write 
AM AM1-AM64 Read and Write 
VB 0-850 Read and Write 
VD 0-847 Read and Write 
VW 0-849 Read and Write 
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1.6.5.2 BM Clock 

Use the BM Clock component to show the date and time information from IDEC SmartRelay 
Base module. 

Create a BM Clock 

You can only read the date and time information from IDEC SmartRelay Base module. 
1. Select the BM Clock component  .

2. Drag the BM Clock component directly where you want it to be in the Editor pane.

3. After you create a BM Clock,

– adjust the BM Clock dimension by dragging the blue square on the border or
modifying the value for Size in the Property pane;

– modify font, text color and background color for the text display in the Property pane.

– move the component by dragging it without clicking the blue squares on the
borderline.

The Properties for BM Clock: 
● Basic

– Name: BM Clock

– Location: you can modify the location coordinate for the text.

– Size: you can modify the width and height information for the text.

● Styles

– Font: select Font, Font Style and Size information separately in the Font pane. Click
the OK button for save the correction or click the Reset to Default button to reset to
the default setting.

– Text Color: click Text Color Swatches, select a swatch, and click OK button.

– Background Color: click Background Color swatches, select a swatch, and click OK
button.

– Fill: click the check box depending on whether to fill the text area with background
color.
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1.7 Editor pane 
The Editor pane is the working space for the project and it shows in the middle of the 
window. It displays the opened pages, tag table and navigator for the project. You can switch 
to different windows for Home Page, Page, Tag Table or Navigator by double-clicking them 
from the Project tree.  

In order to help you maintain an overview of a complete project, the right side and the bottom 
of the Editor pane contain scroll bars, which you can use for vertical and horizontal scrolling 
of the project editing. 

When you edit components in the Editor pane, you can refer to How to edit component 
through the shortcut menu (Page 68). 

1.8 Properties pane 
The Property pane shows the property description of selected component, page or Navigator 
in the project. You can check the detailed property information by clicking them in the Editor 
pane and editing them in the Property pane. 

For detailed information on property for each component, refer to the following table: 

Tool 
Polyline (Page 29) Rectangle (Page 30) Circle (Page 31) 

Basic 
Text (Page 32) Image (Page 34) Link (Page 34) 

Digital 
Digital Value (Page 36) 

Analog 
Analog Value (Page 38) Analog Bar (Page 39) Analog Slider (Page 40) 

Miscellaneous 
Scale Time (Page 41) BM Clock (Page 43) 

Project tree 
Pages (Page 26) Navigator (Page 28) 
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1.9 Graph Library 
Graph Library is the FL1F Web Editor built-in graphics library. You can select graphics for 
the following three components in Property pane. 
● Page: the selection for Background Image;

● Image: the selection for Image;

● Digital Value: the selections for On Image and Off Image;

● Analog Slider: the selections for Background Image and Thumb Image.

Graph Library contains three parts:
● Build-In Graph (Page 45)

● Colors (Page 46)

● My Graph (Page 47)

1.9.1 Build-In Graph 
In the Build-In Graph folder, each subfolder contains different kinds of graphics, such as 
Animation, Automation and Basins. Once you click the subfolder, graphics in this subfolder 
show on the right side of the dialog box. 
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In the Build-In Graph folder, you can do the following: 

● To select the appropriate image, click the image and confirm the selection by clicking OK
button.

● To search for any kinds of image, enter keywords in the entry field and click Search
button or press the enter key, and then the result shows on the right side of the dialog
box.

Note 

For using the search function, 
• the search scope is only available for current selected folder.
• only list the images whose name contains the keywords.

● To copy the selected image to My Graph folder or customized folder, right-click the image
and select Copy To, then the color image appears in My Graph folder or customized
folder.

1.9.2 Colors 
There are different kinds of colors in the Color folder. 

In the Color folder, you can do the following: 

● To select the appropriate color image, click the image and confirm the selection by
clicking OK button.

● To search for any kinds of the colors, enter keywords in the entry field and click Search
button or press the enter key, and then the result shows on the right side of the dialog
box.

● To copy the selected image to My Graph folder or customized folder, right-click the image
and select Copy To, and then the color image appears in My Graph folder or customized
folder.
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1.9.3 My Graph 
My Graph folder is used for creating customized folder. You can import images from local 
disk to both My Graph folder and customized folder. 

In My Graph folder, you can do the following: 

● To create customized folder, right-click My Graph folder and select New Folder, and then
a New Folder appears under the My Graph folder.

Note 
The maximum number of supported customized folder is 20. 

● To rename the customized folder,

– right-click the customized folder and select Rename;

– then the name of the customized folder change to editable state, enter the new name;

– save the change by pressing the enter key.

● To delete the customized folder, right-click the customized folder and select Delete, and
then the customized folder is removed from the My Graph folder.

In My Graph folder or customized folder, you can do the following: 
● To Import image from local disk,

– point to My Graph folder or the customized folder;

– click Upload Files button to find the directory of the image in your local disk;

– click Open button to upload the image;

– then the image appears on the right side of the dialog box.

Note 
• The supported image file formats are as follows: PNG, JPG/JPEG, GIF, TIF/TIFF.
• As for the image with GIF format, if the image size is bigger than 1 MB, it cannot be

dynamic previewed in Graph Library.
• It will take few minutes to upload high resolution images.

● To copy the selected image, right-click the image and select Copy To in shortcut menu,
and then the image appears in My Graph folder or customized folder.
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● To move the selected image, right-click the image and select Move To in shortcut menu,
and then the image move to My Graph folder or customized folder

● To delete the selected image, right-click the image and select Delete in shortcut menu,
and then the image is removed from My Graph folder or customized folder.
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Tutorial 2
2.1 Prerequisites for working with the tutorial 

To use this tutorial, you must be familiar with PC operation and you must know how to create 
a project. To download your project, you also need a PC cable, SD card or Ethernet cable for 
connecting the PC interface to your IDEC SmartRelay device.  

2.2 Getting started with project creation 

2.2.1 Creating a new Project 
After you have installed FL1F Web Editor tool, you can start to create a new project. 

To create a new project, click the File → New Project or click the New Project button in the 
standard toolbar. 

→ File -> New Project (Page 14)

Then a new project contains Pages, Global Tags and Navigator appears in the Project tree 
(Page 25) automatically.  

You can work with IDEC SmartRelay BM to upload (Page 21) or download (Page 19) the 
project, customize the web pages in the Editor pane (Page 44), combine the different 
components from the Component pane (Page 29), modify the component properties from 
Properties pane (Page 44), and visit the whole project through Web Server of the IDEC 
SmartRelay Base Module. 

Note 

When you create another new project, after you click the Finish button to save the setting for 
Name and Location, the current project will be closed. If you haven't saved the current 
project, FL1F Web Editor prompts you to save it. 
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2.2.2 Visiting the project through web page 
After you deploy the whole project, you can visit it through the web page. 
1. Open the web browser and enter the valid IP address of IDEC SmartRelay Base Module.

2. Then the Log on page appears.

3. Enter the Password for IDEC SmartRelay Base Module.

4. Make sure that to select the check box before "to customized site" and click Log on
button.

Then you can view the project in your web browser.

Note 

If you download the modified project to IDEC SmartRelay BM, you'd better log in to the 
corresponding web page again to insure the correction works. 

2.3 Practical example 

2.3.1 Introduction for practical example 
This practical sample is applicable to swimming pool level control and light control systems, 
and offer new users a step-by-step introduction. You learn here how to create a whole 
project and the project contains creation procedures for Pages (Page 51), Global Tags  
(Page 53)and Navigator (Page 54). 

For the detailed configuration information of special components, refer to The example for 
configuring special components (Page 55) chapter. 
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2.3.2 The example for Pages 
In this swimming pool project, there are two pages: 

● Home page is the swimming pool level control system and the page name cannot be
changed;

● Light control page is the swimming pool light control system and the page name can be
renamed.

Home Page for Swimming Pool Level Control 
The swimming pool level control system contains four parts: 
● Tank

– It is used for water storage.

– The block contains Image and Analog Bar components.

● Water valve A

– It is used for connecting tank and swimming pool to control the swimming pool level.

– It has two modes: Auto and Manual operation. And both of the two modes have two
corresponding status: Open or Close.

– The block contains Text, Rectangle and Digital Value components.

● Swimming pool

– It is used for swimming and it use the water-level sensor to monitor the actual water
level.

– The block contains Rectangle and Analog Bar components.

● Water valve B

– It is used for connecting swimming pool and other pipelines.

– It has two modes: Auto and Manual operation. And both of the two modes have two
corresponding status: Open or Close.

– The block contains Text, Rectangle and Digital Value components.
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Page for Swimming Pool Light Control 
The swimming pool light control system contains two parts: 
● The lamp and LED control

– It is used for controlling the lights and recording the running time.

– The block contains Text, Rectangle, Scale Time and Digital Value components.

● Schedule for weekday and weekend

– It is used for controlling the lighting time.

– The block contains Text, Rectangle, Scale Time and Analog Value components.
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2.3.3 The example for Tag Table 
In this swimming pool level control and light control system, you can define both digital value 
and analog value in the Tag Table. Here is an example for eight kinds of variables:  
● The Inlet for Water valve A under the manual mode

● The Outlet for Water valve A under the manual mode

● Level Control for Swimming pool

● Level control for Tank

● Light control for Lamp

● Light control for LED

● Schedule control for Weekday

● Schedule control for Weekend

The variable in Tag table can customize the alias name and it can be bound with some 
components. Below is just an example screenshot. 
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2.3.4 The example for Navigator 
In this swimming pool level control and light control system, the Navigation bar contains 
three options: link to Home Page (renamed to Level Control), link to Light Control page and 
link for LOG OFF button. 

After editing the Navigator (Page 28), the navigation bar allows you to switch between 
different web pages or log off the project. 

Below is just an example screenshot. 
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2.3.5 The example for configuring special components 
There are more than eleven components in the Component pane. In this swimming pool 
level control and light control system, each block combines with several components.  

For detailed configuration for each component, refer to the section Components pane 
(Page 29).  

Configuration for Analog Bar 
In this example, the tank is used for water storage. When the swimming pool water level 
under the target waterline, the system will give an alarm to the user. The user needs to open 
the Water valve A manually to inject water from the tank. For the tank block, it contains 
Image and Analog Bar components.  

Below is just an example screenshot for configuring Analog Bar. 
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Configuration for Digital Value 
In this example, Water valve A is used for connecting tank and swimming pool to control the 
swimming pool level. When the swimming pool water level under the target waterline, the 
system will give an alarm to the user. The user needs to open the Water valve A to inject 
water from the tank manually. For the Water valve A block, it contains Text, Rectangle and 
Digital Value components.  

Below is just an example screenshot for configuring Digital Value. 

Configuration for Analog Value 
In this example, swimming pool use the water-level sensor to monitor the actual water level. 
When the swimming pool water level under the target waterline, the system will give an 
alarm to the user. This water lever monitor panel also can show the total time and time 
remain for injecting water. For this panel, it contains Text, Rectangle and Analog Value 
components.  

Below is just an example screenshot for configuring Analog Value. 
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Configuration for Analog Slider 
In this example, these two sliders are representing target waterline and time remain for 
injecting water. For these sliders, they contain Text, Rectangle and Analog Slider 
components.  

Below is just an example screenshot for configuring Analog Slider. 
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2.3.6 Visiting the example project through web page 
After you finish creating the whole project, you can visit this example project through the web 
page. 

Follow the chapter Visiting the project through web page (Page 50) to open the project, the 
below is just an example screenshot for visiting the example project through web page. 

For more information, refer to ...Tools\FL1F Web Editor \Sample  folder in the DVD ROM. 
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HTML development interface 3
Professional clients can modify the project created by FWE to meet their specific 
requirements on webpage.  

After you bind the HTML element to a BM data, you can monitor the BM data through 
webpage. 

Working principle 
In DBinit(), IDEC SmartRelay JavaScript scans all HTML elements and transfer data with 
those having server_binding class.  

In the server_binding element, we use range, address, type, length to define and bind a data 
from BM.  

Through show_function and show_param, you can implement a callback method to meet 
their requirements based on the data refresh. 

Follow the below rules when you update the project by the interface. Otherwise, it cannot 
work with BM correctly. 
● Except for htm files, do not delete, move or modify other files.

● You can add, modify or delete the htm files in FL1F Web Editor project folder:

– Do not delete main. htm.

– You can only modify the part of a htm file between <div id="main"> and </div>.

– Keep the name of a htm file within 11 characters (a maximum of 8 characters for base
file name and 3 characters for the extension)

● Save the modified projects to webroot of SD card.

3.1 IDEC SmartRelay data access protocol 
For the use of this interface, your pages should include all the following JavaScript: 

<script type="text/javascript" src="/js/utility.js"> 

</script>  

<script type="text/javascript" src="/js/storage.js">  

</script>  

<script type="text/javascript" src="/js/bigint.js">  

</script>  

<script type="text/javascript" src="/js/encrypt.js">  

</script> <script type="text/javascript" src="/js/ajax.js">  
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</script>  

<script type="text/javascript" src="/js/binding.js"> 

</script> 

Note 

You should call the function DBInit() in the page initializing routine, which initializes the data 
binding environments. Otherwise, the refresh framework cannot work. 

3.1.1 Operation 

Define a server_binding element 
Define a server_binding class as below. 
<div comp_type="myDigitalComponent" class="server_binding" 
id="mydiv" show_param="mydiv" show_function="myCallback"   
range="132" address="0" type="1" length="1"  
text 
</div> 

● id: the unique identifier of an element

● class=server_binding: scan identifier for JavaScript framework

● range: the first part of the address

● address: as the third part of the actual address, address means the data offset from the
range start.

● type: data type

● length: data counts with its type.

● show_function: define the function that is used to show the data. This function is a
"callback" function. Framework call the callback function when the binding data is
refreshed.

● show_param: parameter for the callback function.

For more information on the parameters, see Data format (Page 63).

Note 

Ensure all the parameters are included when you define the sever_binding element. 
Otherwise, the data cannot be bound. 
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3.1.1.1 Command 
This chapter introduces some commands related to IDEC SmartRelay data access protocol. 

Get 
To get the data in your webpage, you need to do the following two steps. IDEC SmartRelay’s 
JavaScript framework call the callback function When BM data updates.  
1. Create a server_binding element according to the instruction in Operation (Page 60) .

2. Implement the declared callback function.

See an example as below: 
var myCallback = function myCallback() { 

   //get new value 
   var newValue = parseInt(this.m_sValue, 16); 
   //do your actions... 
  $("#xxx").html(newValue); 

 }}; 

When the callback_function is called, the JavaScript framework receives a parameter 
DBRequest. By this parameter, you can get the server_binding emelent related information 
and the updated data as follow. 

Property Parameter 
DBRequest.m_nAddress address 
DBRequest.m_nLength length 
DBRequest.m_nRange range 
DBRequest.m_nType type 
DBRequest.m_oSrcElement server_binding element 
DBRequest.m_sShowParam show_param 
DBRequest.m_sValue value 

Set 
You need to write your own JavaScript code to implement a set query for a server_binding 
element,  
1. Create a DBRequest object for the server_binding element.

2. Assign a value to DBRequest by SetValue method.

3. Release a set query by SetQuery method.

4. Check the m_iSetPendingFlag member to make sure the SetQuery is complete. The ture
value means SetQuery is pending while the false value means SetQuery is completed.

You can refer to the example below. 

function DBRequestTest () { 

 var oRequest = new DBRequest(document.getElementById("test1")); 

 oRequest.SetValue("00012345"); 

 if(oRequest.SetQuery()) 
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 { 

 while(oRequest.m_iSetPendingFlag) 

 { 

 //wait for a while or give customer some hint. 

 } 

 //done: 

 return true; 

 } 

 //fail: 

 return false; 

 } 

You can also set value for a set of sever_binding elements group. DBGroup object is used 
for collecting the DBRequest objects in this scenario:  
1. Prepare a set of DBRequest objects by the upper description.

2. Create a DBGroup object. Collect the DBRequest objects by Add method.

3. Release the set query by the SetQuery method of DBGroup.

4. Check the m_iSetPendingFlag member to make sure the SetQuery is complete. The ture
value means SetQuery is pending while the false value means SetQuery is completed.

You can refer to the example below. 

function DBGroupTest() { 

 var oRequest1 = new DBRequest(document.getElementById("test1")); 

 oRequest1.SetValue("00012345"); 

 var oRequest2 = new DBRequest(document.getElementById("test2")); 

 oRequest2.SetValue("0x01"); 

 var oGroup = new DBGroup(); 

 oGroup.Add(oRequest1); 

 oGroup.Add(oRequest2); 

 if(oGroup.SetQuery()) 

 { 

 while(oGroup.m_iSetPendingFlag) 

 { 

 //wait for a while or give customer some hint. 

 } 

 //done: 

 return true; 

 } 
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 //fail: 

 return false; 

 } 

Note 

You should call the function DBInit() in the page initializing routine, which initializes the data 
binding environments. Otherwise, the refresh framework cannot work. 

3.1.1.2 Data format 
We use range, sub_range, address, type, length to describe a data. 

The range, sub_range, address indicate the address of the data. The length of a date 
indicates its type. For detailed information, refer to the following table. 

Address 
Space 
Name 

range sub_range address length Recom-
mended 
Access 
Mode 

Reada-
ble/Writable 

Digital Input 129 0 0-63 64 Bits R 
Digital out-
put 

130 0 0-63 64 Bits R/W 

Digital 
Marker 

131 0 0-111 112 Bits R/W 

Variable 132 0 0-6799 6800 Bits, Bytes, 
Words, 
Dwords 

R/W 

Cursor Key 12 0 0-31 32 Bits R/W 
TDE Func-
tion Key 

13 0 0-31 32 Bits R/W 

Shift Regis-
ter 

14 0 0-127 128 Bits R 

NetI 16 0 0-127 128 Bits R 
NetQ 17 0 0-127 128 Bits R/W 
Analog Input 18 0 0-239 240 Words R 
Analog Out-
put 

19 0 0-239 240 Words R/W 

Analog 
Marker 

20 0 0-1023 1024 Words R/W 

NetAI 21 0 0-1023 1024 Words R 
NetAQ 22 0 0-511 512 Words R/W 
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range 
It is the first part of the address. 

sub-range 
It is the second part of the address and reserved for future function extension. The default 
value is 0. 

address 
As the third part of the address, it means the data offset from the range start. 

Note 

Ensure that you provide the offset-address by bits no matter what data type you are 
accessing. 

All the address will be validated before access. IDEC SmartRelay reports an error for an 
invalid address and truncate the address which is out of range. 

type 
It means data type. IDEC SmartRelay has four kinds of data. 

Id type length 
1 BOOL 1 bit 
2 BYTE 8 bits 
4 WORD 16 bits 
6 DWORD 32 bits 

length 
It means the data count with its type . 

value 
All data value is presented by a HEX string.  You can convert it into other type for your 
customer, but you must convert it back to HEX array mode before you set it to server. 
 For example, as for data with type DWORD, its value is 0x12345, you will get the string 
“00012345” from server, and if you want to change it to 0x12346, you also should use string 
“00012346”. 
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3.2 Example 
Below is an example of digital component. 

<BODY onload="loadPage()"> 

 <DIV  id="wrap"> 

 <div id="main" onclick="hideMenu()" style="width: 1420px; height: 880px;"> 

    <div comp_type="myDigitalComponent" class="server_binding" id="mydiv" 

show_param="mydiv" show_function="myCallback"  

 range="132" address="0" type="1" length="1" 

 onclick="sendDigitalRequest(this)" value="0" 

 style="position:absolute; left:389px; top:242px; width:84px; 

height:84px; border:1px solid red;line-height: 84px;"> 

 OFF 

  </div> 

 <script type="text/javascript"> 

 var myCallback = function myCallback() {    

 var id = this.m_sShowParam; //get id 

 var newValue = parseInt(this.m_sValue, 16); // get newValue  

 document.getElementById(id).value = newValue;// recode the newValue 

    //response 

 if (newValue == 0) { 

 $("#"+id).html("ON"); //do your actions 

   } else {    

 $("#"+id).html("OFF"); //do your actions 

 }}; 

 function sendDigitalRequest(obj) { 

 var id = obj.id; 

 var oRequest = new DBRequest(obj); 

    //set value 

 if (obj.value) { 

 oRequest.SetValue("00"); 

 } else { 

 oRequest.SetValue("01"); 

 } 

    //send request 

 if (oRequest.SetQuery()) { 
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 setInterval(checkResult, 1000, oRequest); 

 } 

 } 

    </script> 

 </div>  

 </DIV> 

 </BODY> 

Specification 
1. All you custom codes have to be added  between <div id=”main”>  and </div>.

2. The following four parameters define the IDEC SmartRelay data access and callback
JavaScript function:

– class="server_binding": IDEC SmartRelay JavaScript will scan all the DIVs and
transfer data with those DIV having server_binding class.

– id="mydiv" : You should assign id and show_param with the same DIV.

– show_param="mydiv": You should assign id and show_param with the same DIV.

– show_function="myCallback":You need to implement a callback JavaScript function
and assign its name to “show_function”.

3. The following four parameters describes the data:

– range="132": V

– address="0":0.0

– type="1":BOOL

– length="1": 1

For detailed information, see Data format (Page 63).
4. The following two parameters are used to submit requests to server.

– "setDigitalData(obj)" : it’s a customized method, used to submit requests to server.

– "value": used to recode the current data value and could be submitted by
"setDigitalData(obj)".
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Tips and tricks 4
4.1 How to display a corresponding tooltip for a function key 

In FL1F Web Editor, you can display a corresponding tooltips both in Standard toolbar and 
Graphic Library. 

Tooltips for Standard toolbar 

In the Standard toolbar, you can use the mouse-over-button function to display the icon 
name, which represents the tooltip. This helps you quickly recall the function of the icon, 
without having to call the menu or the help. 

Below is an example screenshot. 

Tooltips for images in Graphic Library 

In Graphic Library, you can also use the mouse-over-button function on each image to 
display the File Name, Item Type, Dimensions and Size information which represents the 
tooltip.  

Below is an example screenshot. 
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4.2 How to draw a polyline well 
When you active the Polyline component, you can draw the polyline start from left-clicking 
mouse button and end with right-clicking mouse button. 

Every point you click appears a blue square, and a blue arrow goes with your mouse. When 
you finish drawing for the polyline, you'd better move your mouse away from the blue square 
and do the right-click, or else the shortcut menu for right-click function will be popped up. 

4.3 How to edit component through the shortcut menu 
Right-click the component to open a shortcut menu that offers you the following functions for 
editing the component: 

● Copy (Page 18)

● Paste (Page 19)

● Delete (Page 19)

● Bring To Front (Page 18)

● Send To Back (Page 18)

● Left Rotate (Page 18)

● Right Rotate (Page 17)
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4.4 How to import multiple images 

Import multiple images in Graphic Library 
1. Point to My Graph folder or the customized folder where you want to attach the images.

2. Click Upload Files button to find the directory of the image in your local disk;

3. Choose the images you want to upload. You can upload multiple images in two ways:

– To choose a list of sequential images, click the first file you want to upload, hold the
Shift key on the keyboard and click the last file you want.

– To choose non-sequential images, click the first file you want to upload, hold the Ctrl
key on the keyboard and click any further files you want to upload.

– To choose all the images, hold the [Ctrl+A] key on the keyboard.

4. Click Open button to upload the images;

5. Once uploaded you will see the uploaded images appear on the right side of the dialog
box.

4.5 How to add a link connecting to another page 
To add a link connecting to another page in your project, you need to add these parameters 
after your URL: 

 ?!App-Language=" +  

LocalStorage.Instance().Get("pdt_current_language") + "&Security-Hint=" + 

LocalStorage.Instance().Get("pdt_current_login_ref"); 

Example:  

window.location.replace(link + "?!App-Language=" +  

LocalStorage.Instance().Get("pdt_current_language") + "&Security-Hint=" + 

LocalStorage.Instance().Get("pdt_current_login_ref")); 
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